最近気になる検証環境で利用したいハードウェアとして Minisforum MS-01 があるのですが、自分の用途で気になった内容をメモとして。
SQL Server on Azure VM の SQL Server 日本語化後の IaaS Agent の導入を Bicep で実施する
Azure では、Marketplace から SQL Server インストール済みの VM イメージが公開されており、Azure VM で SQL Server を使用する場合は、このイメージで展開して PAYG で利用するのが一般的かと思います。
イメージは英語版を使用して構築されているため、日本語化する場合には、当ブログで書いた SQL Server on Azure VM (インストール済みイメージ) の日本語化 (2021/1 版) の方法や、SQL Server Support Blog で公開されている次の記事の対応を行う必要があります。
基本的な作業としては、次の流れとなるのではないでしょうか。
- OS に日本語の言語パックをインストールし、各種言語設定を日本向けに設定
- 導入済みの英語版 SQL Server / SSMS をアンインストール
- SQL Server の日本語版評価版メディアをダウンロードして「C:\SQLServerFull」内のプロダクトキーでインストール
- 日本語版の SSMS をインストール
- SQL Server IaaS Agent 拡張機能を Remove-AzSqlVM 等で登録解除
- New-AzSqlVM で SQL Server IaaS Agent 拡張機能を登録
基本的な作業の流れとしてはこのようになりますが、この手順だけでは、VM の展開時に指定した SQL Server 構成の設定はクリアされた状態となってしまっています。
展開時に指定した内容と同等の設定で IaaS Agent を導入するためには、New-AzSqlVM で様々なオプションを指定して再導入をする必要があるのですが、オプションを一つ一つ設定するのは手間がかかるため、今回はその設定を Bicep で実施してしまおうというのが今回の趣旨となります。
JDBC で HikariCP を使用した SQL Server (SQL Database) への接続について調べてみる
JDBC で接続をする際のコネクションプールで使用するライブラリとして HikariCP があります。
HikariCP を使用して SQL Server に接続をする際の挙動について、いくつか調査する必要があったのでその時に確認した内容を残しておきたいと思います。
Build 2024 のタイミングで発表された SQL Database に関連するアップデート
Build 2024 が開催されています。
キーノートについては次の情報から確認できます。
- Build 2024 Book of News
- Microsoft May 2024 events
- Full Keynote: Satya Nadella at Microsoft Build 2024
SQL Server についてはアップデートはなかったのですが、Azure SQL Database についてはアップデートがアナウンスされていますのでまとめておきたいと思います。
Dev Container を使用して SqlPackage の実行環境を作成する
SQL Server ベースの環境に対しての CI/CD で活用できるツールとして SqlPackage があります。
Visual Studio Code の Dev Container (開発コンテナー) 上に SqlPackage の実行環境を作成しようかなと思って試してみました。
SqlPackage に問題がある場合は DacFx のリポジトリ から Issue で報告ができます。
プライベートリンクを使用した Microsoft Fabric への接続制御
Microsoft Fabric のネットワーク接続で使用できる機能をまとめておきたいと思い、最初にプライベートリンクを使用した Microsoft Fabric への接続制御 (受信方向)
Fabric のセキュリティについては次のドキュメントから確認できます。
パブリックアクセスをブロックすることで、プライベートエンドポイント経由でのみ、Fabric へのアクセスを許可することができますが、Fabric にデータを格納するための既存のパイプラインのアクセスにも影響がでる可能性があります。
パブリックアクセスをブロックする場合には、途中からブロックするのではなく最初からブロックする設定を行っておいたほうが良いかと。(私が使用している環境では、ADF から Fabric へのインポートがブロックされるようになり、ADF で作成していた Fabric 向けのパイプラインがエラーとなりました)
Azure VM でリソース名と異なるホスト名で展開を行う
Azure のリソース名のルールとして、次のようなドキュメントが公開されています。
Azure Portal から VM を展開した場合、VM のリソース名が展開後の VM のホスト名として設定されますが、Windows ではコンピューター名の上限が 15 文字となっています。
はい。 コンピューター名は最大 15 文字の長さまで指定できます。 リソースの名前付けの詳細については、名前付け規則と制約事項に関する記事を参照してください。
1-15 (Windows)
1-64 (Linux)
下記の「注意」を参照。Azure 仮想マシンには、リソース名とホスト名の 2 つの異なる名前があります。 ポータルで仮想マシンを作成すると、両方の名前に同じ値が使用されます。 前の表に記載されている制限事項は、ホスト名に適用されます。 実際のリソース名の最大文字数は 64 文字です。
Windows の場合、15 文字の制限があるため、15 文字を超えるリソース名を設定した場合は 15 文字に省略されてホスト名が設定されます。
名前付け規則を定義する の案として次のような形式が提示されていますが、VM のリソース名でこのルールを適用した場合、15 文字の制限に達する可能性があるのではないでしょうか。
展開後に、ホスト名を表示および変更する の方法で変更することもできるのですが、本投稿では展開時に任意のホスト名を設定した状態で展開をしてみます。
az bicep install を実行すると SSL: CERTIFICATE_VERIFY_FAILED のエラーが発生した場合の対応
事象としては、az bicep install error #25471 となりますが、Bicep を使用するために「az bicep install」を実行すると、ネットワーク環境によっては次のようなエラーが発生することがあります。
Error while attempting to retrieve the latest Bicep version: HTTPSConnectionPool(host=’aka.ms’, port=443): Max retries exceeded with url: /BicepLatestRelease (Caused by SSLError(SSLCertVerificationError(1, ‘[SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed: self signed certificate in certificate chain (_ssl.c:1006)’))).
Bicep のインストールを実施する際には、最新の情報を「https://aka.ms/BicepLatestRelease」から取得しているのですが、プロキシなどが入っている環境ではこの情報を取得する際にエラーが発生するようです。
SQL Server / SQL Database Update (2024/03/04~2024/05/12)
前回の Update: SQL Server / SQL Database Update (2024/01~2024/03/03)
前回の投稿以降の Update をまとめておきたいと思います。
- Azure Updates
- Preview
- GA
- Azure SQL Blog
- SQL Server Blog
- SQL Server
- SQL Database
- Azure Arc